Test Driving Linux/A Free Office Suite

From WikiContent

< Test Driving Linux
Revision as of 23:05, 11 March 2008 by Docbook2Wiki (Talk)
(diff) ←Older revision | Current revision (diff) | Newer revision→ (diff)
Jump to: navigation, search
Test Driving Linux


Have you ever purchased car accessories from a dealership? If so, you know that these can be some of the most expensive items you ever get for your car. Floor mats can cost several hundred dollars, a rear spoiler on your trunk close to a thousand, and a stereo system can run from a few hundred to more than a thousand, depending upon its features.

What some people don't realize is that they can get the same accessories elsewhere, for far less money. Those floor mats will cost only $30 or so from an AutoZone. An aftermarket rear spoiler, painted to match your car's color, is half the price you'd get from the dealership. And as for the stereo, you can get better quality and brand selection from Circuit City or Best Buy at a fraction of the cost.

As you might guess, the same is true in the world of computers. Just like with cars, there are alternatives to purchasing from the computer dealer. For example, you can buy your memory from a third party such as Crucial (http://www.crucial.com) and get a low-priced, high-quality product. But what's the alternative to the ubiquitous Microsoft Office suite that comes with so many new computers?

The answer is the OpenOffice.org office program. This office suite is entirely free, both in price and in the openness of its code. You can use it right now on the Move CD, or download it from http://www.openoffice.org for use on another computer. It runs on Windows, Linux, Mac OS X, and Solaris (a Unix operating system). It may have a strange name, but that doesn't mean it isn't a very capable office suite. It can even open Microsoft Word, Excel, and PowerPoint documents, and save back as those formats.

Note


OpenOffice.org sounds more like a web site than an office suite—and actually, it's both. The reason it isn't just called OpenOffice is that some other company already claimed that name. By the time the OpenOffice.org people realized that, everyone was used to the name, and the project didn't want to switch. You will often see the name abbreviated as OOo.

Contents

The OpenOffice.org Office Suite

Just a few years ago, OpenOffice.org wasn't free at all. It was a product called StarOffice, sold by a German company called StarDivision. The big Unix company Sun Microsystems bought the code for StarOffice in 1999, and some time afterward they open-sourced as much of it as they could and named the resulting project OpenOffice.org. (Sun continues to sell a version of OpenOffice.org called StarOffice, which is basically OpenOffice.org plus some pieces that couldn't be open-sourced—some fonts, a database component, some templates, and a lot of clip art.)

OpenOffice.org contains several programs that are similar to the applications in Microsoft Office. Although it lacks a personal information component like Microsoft Outlook (see Chapter 6 for a discussion of Kontact, an alternative open source program), it has pretty much everything else in the standard Microsoft Office Suite, in addition to a few unique features of its own. The programs in OpenOffice.org are:

Writer
Writer is a word processing program that you can use to create all kinds of documents, from simple letters and resumes to complex documents such as books or a college thesis. Writer also includes a component that lets you create web pages of mid-level complexity.
Calc
The Calc spreadsheet program is a very capable replacement for Excel. It supports hundreds of functions to perform complex calculations, charting, and integration with outside data sources. However, note that although Calc has its own macro language, it cannot run Excel macros.
Impress
Impress allows you to create presentations in a similar manner to PowerPoint. It lacks PowerPoint's diversity of effects, but it is still capable of creating very nice presentations. One useful feature is that you can save presentations to a Flash file, which lets you easily put your presentations on the Web.
Draw
The Draw program is a handy tool to manipulate images or create artwork. Its capabilities fall somewhere between those of Paint and Photoshop, and it makes a nice complement to the GIMP, a photo editing program covered in Chapter 7. If you like using WordArt in Word, you'll love this program.
Math
The Math component of OpenOffice.org ties in with the other programs, particularly Writer, and allows you to display complex mathematical formulas, which makes it useful when writing scientific or engineering papers.

This chapter covers only Writer and Calc, the two most commonly used components in OpenOffice.org. But these are big, feature-rich programs, and though I'll provide an overview that should answer all your basic questions, you may well want to research them further after reading this chapter. For more information about Writer, check out OpenOffice.org Writer: The Free Alternative to Microsoft Word (O'Reilly). For more information about the entire office suite, pick up a copy of The OpenOffice.org Resource Kit (Prentice Hall).

Note


If you download a copy of OpenOffice.org to use on your Windows or Linux computer, feel free to make copies for your friends. It's perfectly legal to make a hundred copies and give them away to whoever you want. You could install copies on every machine in your office and never have to pay a dime. (But of course, you'll want to make sure your system administrator is okay with that.)

Writer Basics

In most ways, you'll find that Writer operates a lot like Microsoft Word. It has many of the same features; they're just in different places. This section will familiarize you with the basics of Writer.

You can launch Writer by clicking K Menu→ Use office tools→ Create a text document. Be prepared for a wait—Writer takes a long time to open not only when it's launched from a live CD, but it takes about 10 seconds even when it is installed to your hard drive. Happily, though, load times are improving with each new release.

When Writer comes up, you'll see a window that looks a lot like Word: menus along the top, icon bar just below that, and a large space just waiting for you to start typing.

Open and Save Files

To open a file, select File→ Open or use the keyboard shortcut Ctrl-O. In the Open window, browse through the filesystem, select the desired file, and click the Open button. This browse dialog is similar to what you see in KDE applications, but not identical. This is because OpenOffice.org is not a KDE application, and therefore doesn't use KDE's built-in methods to open and save files.

To save a document, just select File→ Save or use the keyboard shortcut Ctrl-S. If it's a new document, Writer asks where you want to save the file. If it's an existing document, Writer just saves on top of the previous version.

If you want to put the file in a different directory or change the filename or file type, select File→ Save As. Make the appropriate selections in the Save As window and click the Save button. You can save a document in Microsoft Word format by simply choosing Microsoft Word from the "Save as type" drop-down list before you click Save.

Note


If you save a document in MS Word format and then close Writer, you will get a warning that "Saving in external formats may have caused information loss." Don't worry about this too much. If anything is lost, it will just be some formatting, not actual text. This warning is really just a last chance to also save the document as an OpenOffice.org document.

Compare Features of Writer and Word

One of the most common complaints lodged by new OpenOffice.org users—or by people trying to delay a forced migration to a new OpenOffice.org—is, "It doesn't have my favorite feature. It's missing the one thing I need to get my work done!"

But the truth is that Writer has most of the features offered by Microsoft Word. Not only that, it has a few significant features that Word lacks and that make Writer more suitable than Word for large and multi-chapter documents. However, the problem is that corresponding features may be located in a different place or labeled under a different name than in MS Word, so you might just need a little help to find your favorite feature.

Table 9-1 familiarizes you with the new terminology and layout of Writer.

Table 9-1. Feature comparison of Word and Writer

Feature name Word 2000 Writer
AutoCorrect Tools→ Autocorrect Tools→ AutoCorrect/AutoFormat
AutoNumbering Format→ Bullets and Numbering Format→ Numbering/Bullets...
Compare Documents Tools→ Track Changes→ Compare Documents Edit→ Compare Document...
Envelope Tools→ Envelopes and Labels Insert→ Envelope...
Go To Edit→ Go To Edit→ Navigator
Header and Footer View→ Header and Footer Insert→ Header→ DefaultInsert→ Footer→ Default
Insert Clip Art Insert→ Pictures→ Clip Art Tools→ Gallery
Labels (create) Tools→ Envelopes and Labels File→ New→ Labels
Master Document View→ Outline File→ New→ Master DocumentFile→ Send→ Create Master Document
Mail Merge Tools→ Mail Merge Tools→ Mail MergeView→ Data Sources
Page Numbers Insert→ Page Numbers Insert→ Fields→ Page Number
Record Macro Tools→ Macros→ Record New Macro Tools→ Macros→ Record Macro
Styles Format→ Styles Format→ Styles→ CatalogFormat→ Styles→ LoadFormat→ Stylist
Table (insert) Table→ Insert→ Table Format→ Autoformat...Insert→ Table
Track Changes Tools→ Track Changes Edit→ Changes→ chk `Record,' chk `Show'
Word Count Tools→ Word Count File→ Properties→ Statistics

Writer's Toolbars

The important toolbars in Writer are the Main Menu, the Function Bar, the Object Bar, and the Main Toolbar. Figure 9-1 shows the main Writer window with the various toolbars labeled.

Figure 9-1. The Writer toolbars

The Writer toolbars

Main Menu
Contains the File, Edit, View, Insert, Format, Tools, Window, and Help menus. You can also view each menu by pressing the Alt key along with the first letter of the menu name (Alt-F for the File menu, for instance).
Function Bar
Contains the Open a Recent Document drop-down menu, the Open New Document, Open File, Save Document, Edit File, Export to PDF, and Print File icons, and other handy icons for one-click execution of common functions.
Object Bar
Contains the Document Styles drop-down menu, the Fonts & Font Size drop-down menus, and options for bold, italic, underline, indents, bullets & numbering, and character coloring.
Main Toolbar
Contains Insert Table, Insert Fields, Insert Objects, Spellcheck, Data Sources, and other tools. This toolbar lies along the left edge of the Writer window.

And these are merely the default toolbars that are visible out of the box. You can display other toolbars by customizing your setup, as described in the following section.

Additional toolbars in Writer include:

  • Table Object Bar
  • Numbering Object Bar
  • Frame Object Bar
  • Draw Object Bar
  • Control Bar
  • Text Object Bar/Graphics
  • Bezier Object Bar
  • Graphics Object Bar
  • Objects
  • Text Object Bar/Web
  • Frame Object Bar/Web
  • Graphics Object Bar/Web
  • Object/Web
  • User-defined no.1

To hide any of the toolbars (except for the Main Menu), right-click in the empty space within the toolbar and uncheck the toolbar's name. You can also rearrange elements in a toolbar and redesign it to your personal preference by right-clicking in the toolbar and choosing any of the four options in the bottom half of the right-click menu:

Visible Buttons
Check (to display) or uncheck (to hide) specific buttons/icons that appear on that toolbar.
Configure...
Customize and allocate which toolbars are available.
Customize...
Call up the Customize Toolbars dialog, which offers a grand array of buttons to add to any toolbar.
Reset
Restore the default configuration for all toolbars.

Changes made using the first three commands apply only to the specific toolbar on which you right-clicked to call up the context menu.

Document Formatting

When writing documents you often want to use special formatting, such as bold, italic, underlining, special fonts, different font sizes, and indentations. The Object Bar in Writer provides basic character formatting buttons. These buttons can help you execute quick formatting changes with one click.

Figure 9-2 shows the available formatting buttons, which allow you to make fancy changes such as coloring text and creating bulleted or numbered lists. And you can use the B, I, and U buttons to set text as bold, italic, and underlined, respectively. (You can also do this using the familiar keystroke combinations Ctrl-B, Ctrl-I, and Ctrl-U.)

Figure 9-2. The formatting buttons on the Object Bar

The formatting buttons on the Object Bar

In Writer, there's no need to highlight a whole word in order to format it. As long as your cursor is somewhere within the word when you apply formatting changes, Writer will change the format of the whole word. This saves extra mouse maneuvers or keystrokes. Direct changes can also be made to sequences of characters or to whole paragraphs:

Character formatting
The Object Bar buttons allow you to make simple formatting changes, but if you have more unusual needs, such as applying advanced font formatting, you'll need to use the Character window. To do this, highlight the character or characters you want to change and go to Format→ Character.... You can then make more advanced formatting changes in the Character window.
Paragraph formatting
You can also indent, align, set borders, and manipulate paragraph formats by going to Format→ Paragraph.... The Paragraph window is shown in Figure 9-3. If you highlight multiple paragraphs first, changes will be applied to all selected paragraphs; if you don't highlight anything, paragraph changes will affect only the paragraph in which the cursor is currently placed.

Figure 9-3. The Paragraph window

The Paragraph window

Headers and Footers

Headers and footers are the text or other content that you wish to appear at either the top (header) or bottom (footer) of every page of a document or section.

To insert a header, select Insert→ Header→ Default. This opens a header frame in the document, where you can type or enter the content that should appear at the top of every page. To insert a footer, select Insert→ Footers→ Default.

Most documents use headers or footers to display page numbers. To generate automatic page numbers, insert either a header or a footer and click once inside the header or footer frame. Go to Insert→ Fields and select Page Number in the drop-down menu. This inserts the page number automatically at the location of the cursor.

You may sometimes want to use page numbering that states both the page number and the total number of pages in the document, giving you a footer that reads "Page 16 of 96," for example. To use this format, place the cursor in the target location in the header or footer and type Page followed by a space. Then insert the Page Number as shown previously, type of followed by a space, and insert Page Count from the same drop-down menu.

Print Documents

You can print a document in one stroke by simply clicking the printer icon on the Function Bar. It looks just like the print icon in MS Word and most other programs.

You can also print documents from the Print window (Figure 9-4), which you can bring up by selecting File→ Print or simply pressing Ctrl-P. Here, you can choose a non-default printer (if one is set up), a limited page range, or the number of copies for your print job.

Figure 9-4. The Print window

The Print window

Save or Export to Common File Formats

OpenOffice.org facilitates saving files in several different file types, including some very useful document standards such as PDF. By choosing the format in which you save a document, you can ensure that your work is viewable and editable by people who don't have OpenOffice.org. (Of course, they could always just go and download OpenOffice.org—it is free, after all!)

To save your document as a Microsoft Word file, choose File→ Save As..., open the File Type drop-down menu, and select the desired MS Office file format version. Choices include:

  • Microsoft Word 97/2000/XP (.doc)
  • Microsoft Word 95 (.doc)
  • Microsoft Word 6.0 (.doc)

To create a PDF of your current document, click the small, red Export to PDF icon on the Function bar. The Export window will open with the file format preselected to Adobe PDF, as shown in Figure 9-5.

Figure 9-5. The Export window

The Export window

Enter a filename for the new PDF file, choose a folder in which to save it, and press the Export button. You can also bring up the Export window by selecting File→ Export as PDF.

Advanced Formatting with Styles

Styles are one of the most powerful and important features of word processing. Using styles, you can create consistency of appearance and formatting in a document or across documents. A style is simply a saved set of formatting choices that you can then apply with just a few mouse clicks. As an example of using styles, imagine that you've created a 100-page document with a lot of headings, and you later decide that you need to make the headings bigger so they will stand out more. If you originally applied your heading font sizes manually, you would need to go through each heading one at a time in order to change its font size. However, if you used a heading style to create all your headings, all you'd need to do is change the font size in the style, and all of your headings would update automatically. It's easy to see how this could save you a lot of time and prevent a lot of formatting errors. Styles even make it possible for a group of people to maintain a consistent look in all of their documents, which is useful in a business setting.

The Stylist

In Writer, the interface to the Styles toolset is a floating palette called the Stylist. You can open the Stylist by pressing the Stylist on/off button on the Function Bar (the button looks like a page with a tiny hand in the corner). Alternately, you can press the function key F11.

The Stylist lets you toggle among five different style types or categories, each of which applies to a specific type of text or element, as described in the following list:

Paragraph Styles
Set formatting for a whole paragraph, note, sidebar, list, frame, table, or other collection of set-off text.
Character Styles
Apply to a word, single character, or selection of characters.
Frame Styles
Set formatting for frames that might include such content as text, a bulleted list, graphics, charts, or other frames.
Page Styles
Apply an entire set of Styles to a whole page. This is the tool you use to apply style sets to chapters and title pages.
Numbering Styles
Apply a numbering format to numbered lists.

The default state of the Stylist is to open in Paragraph Styles with the Automatic mode, as shown in Figure 9-6. To switch from one style category to another, simply click the corresponding icon at the top left of the Stylist's toolbar.

Figure 9-6. The Stylist opens to Paragraph Styles

The Stylist opens to Paragraph Styles

Apply a Character Style

One of the simplest things you can do with the Stylist is apply one of its default character styles. To do this, click on the Character Styles icon at the top of the Stylist (the second icon from the left, showing an A). This reveals all the default character styles available, as shown in Figure 9-7 (the window is in All mode by default).

Figure 9-7. The Stylist in Character Styles, ready to paint bold

The Stylist in Character Styles, ready to paint bold

For example, to apply a bold style, highlight the bold character style (at the top of the list by default) with a single click and then click once on the paint-can icon at the top right corner of the Stylist. When you click the paint can, your cursor turns into a little paint-can tool that makes it easy to apply your chosen style with precision. Click on the word you want to set in bold or drag the paint-can cursor across some text. As you can see, the paint can gives you a Midas touch, turning everything you click into bold. You can turn off the style by pressing F11, by clicking on the X icon at the top right of the Stylist box, or by choosing a different style.

Modify Styles

You can also modify the behavior of a built-in style. For instance, if you want list items to be indented differently than the default, you can edit that list style and make it indent all your lists the way you want. Note that when you modify an existing style, it immediately takes effect on all items in the document that are tagged with that style, as well as items you create in the future.

To modify a style, select Format→ Styles→ Catalog... to bring up the Style Catalog, as shown in Figure 9-8. The Style Catalog displays different styles depending on the style used at the cursor's current location. Highlight the style you want to alter ("Default" in the figure) and click the Modify button on the right side of the window. This opens the Style Settings window for the Default style, as shown in Figure 9-9; here, you can change any characteristic that is available for modification.

Figure 9-8. The Style Catalog

The Style Catalog

Figure 9-9. The Style Settings window for the Default paragraph style

The Style Settings window for the Default paragraph style

Alternately, you can modify a style by right-clicking on the style in the Stylist and choosing Modify to open the Style Settings window.

Borrow Styling

Writer also makes it easy for you to quickly change an existing Style by applying the format of a selected character, paragraph, or page. To update a particular style, press the function key F11 to open the Stylist and click the icon of the style type you want to update: Paragraph, Character, or Page. Then, click once in the document in the place from which you want to copy/update the style—for example, you may be "borrowing" paragraph formatting that you had previously applied manually. Next, click on the style name you wish to update in the Stylist, and then click the Update Style icon at the far right of the Stylist toolbar.

Add or Create New Styles

Although Writer comes with many predefined Styles, you may have specialized documents that require an entirely new Style. Writer makes it easy to create new Styles, too.

To add a new style to the Stylist, first open the Stylist by pressing F11 and select a style category. Highlight an existing style upon which you want to base your new style; it should be as similar as possible to the one you wish to create. Right-click that style and select New... to open the Style Settings window shown in Figure 9-9. Here, you can set all the characteristics you want for the new style, including its category.

Work with the Navigator

The Navigator is a floating panel, like the Stylist, that adds horsepower to your movements within a document. You can turn on the Navigator by clicking the Navigator button on the Main Menu (just to the left of the Stylist button) or by pressing the function key F5.

Figure 9-10 shows the Navigator panel with the major categories, Headings, Tables, Bookmarks, Hyperlinks, and Notes, collapsed. If you click the plus sign in front of the Headings category, for example, all headings within your current document will be revealed. Double-click on one of these entries to move to that place in the document.

You can also use the Navigator to easily move sections of the document. This is a great way to quickly reorganize a document, without having to do a lot of cutting and pasting in the main window. To move things around, click on a section name to highlight it, and then click one of the icons in the top right of the Navigator window to promote or demote the section (which Writer calls a chapter).

Figure 9-10. The Navigator in collapsed view

The Navigator in collapsed view

In addition to the major categories, Navigator displays a variety of different object types in its panel, allowing you to move quickly among sections and types of elements in a document.

Other Features in Writer

There are hundreds of features in Writer. What I've written so far barely scratches the surface, but it should be enough to get you started. This section describes several other features you might find useful.

Use the Changes Tracking Feature

In business situations you often want to have someone else review one of your documents. For example, perhaps you've written a proposal and want to have a coworker look it over before you submit it to your boss. Wouldn't it be useful to be able to see your coworker's comments and edits in the document? Like MS Word, Writer offers a great tool that allows you to do just that. When you track changes onscreen, each person's edits appear in a different color, which makes it easy to tell who changed what. To turn on Changes Tracking in Writer, select Edit→ Changes and single-click both Record and Show. Now you'll be able to track and see any changes made to the document. Keep in mind that once turned on, these settings "travel" with the document when it is saved, and will stay on until someone unchecks them and saves the document again.

As a writer, I use the Changes Tracking feature all the time when reviewing documents with my editor. If you need to have other people review your documents for any reason, you'll find this feature an invaluable tool.

Save Time with Keyboard Shortcuts

Keyboard shortcuts can be enormously helpful in speeding up your work. I use them all the time—in fact, I couldn't live without them! You'll find that it's often faster to use keyboard shortcuts than to use mouse clicks and drop-down menus, because using keystrokes allows you to keep both your hands on the keyboard at all times. This can also help you to avoid repetitive stress syndrome, which often develops through excessive use of the mouse. Table 9-2 lists some common keyboard shortcuts that you can use to do various things quickly within a document.

Table 9-2. Common keyboard shortcuts

Function Keyboard shortcut
Copy text Ctrl-C
Cut text Ctrl-X
Paste text Ctrl-V
Bold text Ctrl-B
Italicize text Ctrl-I
Underline text Ctrl-U

Use Find and Replace

To find and replace characters in a Writer document, press Ctrl-F to open the Find & Replace dialog (see Figure 9-11). Alternately, you can access this dialog by selecting Edit→ Find & Replace.....

Figure 9-11. The Find & Replace window

The Find & Replace window

Enter the term you want to find in the "Search for" field; if you want to change this term to another word, enter the new word in the "Replace with" field. Then press the Find button at the top right of the window. Starting from the current location of your cursor, Writer will locate the next instance of the term you're searching for.

Once you find the term, just press the Replace button to put in the new word. If you come to an instance that you don't wish to replace, just press the Find button again to advance to the next example of the search term.

It's usually a good idea to place your cursor at the beginning of the document before commencing Find & Replace. You can also go from your current point to the end of the document, and then let the search process start over from the beginning of the document when you are prompted to do so.

Calculate Word Count

Journalists, authors, and editors depend on this feature for their daily bread, so they can be forgiven for their oft-reported anxiety that Writer doesn't include a word count feature. In fact, word counting is indeed available in Writer—it's just in a mysterious location. It's under File→ Properties→ Statistics, whereas in MS Word it's under Tools→ Word Count. (See the Feature Comparison chart in Table 9-1.)

Change Unpopular Default Settings

By default, OpenOffice.org is set to automatically complete words, replace certain characters, and capitalize initial letters in a new sentence. If you find such autocorrection intrusive while you're typing, it's easy to adjust the settings or turn them off completely.

Word Completion

Writer's Word Completion feature is turned on by default. If you like to have Writer complete your words, simply press the Enter key when its recommendations are good and press the space bar to reject the suggested word.

On the other hand, if you find Word Completion annoying and want to turn it off, select Tools→ AutoCorrect/AutoFormat→ Word Completion and uncheck the box before the phrase "Enable word completion" near the top of the window. Then click the OK button.

Auto-Replace

If you find Auto-Replace annoying—such as when you try to type (c) and it keeps replacing it with the copyright symbol ©—you have two options: edit the replacement list, or turn off Auto-Replace altogether.

Editing the replacement list is straightforward. Select Tools→ AutoCorrect/AutoFormat, go to the Replace tab (Figure 9-12) and highlight the offending element. Then, either press the Delete key or enter a different target result in the With: field.

Figure 9-12. The default replacement list

The default replacement list

To turn off the Auto-Replace function entirely, select Tools→ AutoCorrect/AutoFormat and click on the Options tab. The topmost option is "Use replacement table," with two checkboxes in front. By unchecking both boxes in the [M] and the [T] columns, you can turn off the specific substitutions listed in the replacement table. You can also turn off any other specific automatic replacement actions by unchecking the respective boxes under [M] or [T] as you go down the list.

Before you disable Auto-Replace entirely, note that the list of default replacements in the Replace tab is based on the OpenOffice.org developers' extensive knowledge of common keystroke errors and frequently used symbols (such as the copyright symbol). Leaving Auto-Replace turned on can aid your productivity, especially if you customize the replacement list with your own most frequent word, character, or symbol replacements.

Auto-Capitalization

Writer is set to automatically capitalize the next character you type after a period and to lowercase a second uppercase character typed in a sequence. This is beneficial most of the time, but it can be annoying when you try to type abbreviations or acronyms that include two initial capitals.

You can turn off the Auto-Capitalization feature by selecting Tools→ AutoCorrect/AutoFormat and clicking on the Options tab. Uncheck the two boxes under the [M] and [T] columns in front of the second option, "Correct Two Initial Capitals," and the third option, "Capitalize the first letter of every sentence."

However, Auto-Capitalization can be very helpful when you integrate it into your typing repertoire. Consider keeping the feature turned on and tweaking its exceptions to make it work for you instead of against you. You can adjust the Auto-Capitalization exceptions by selecting Tools→ AutoCorrect/AutoFormat and going to the Exceptions tab (see Figure 9-13). Here, you can add abbreviations you use frequently to the "Abbreviations (no subsequent capital)" list in the upper window. These entries tell Auto-Capitalization not to automatically capitalize the first letter after any of the abbreviations listed. You can also add to the list of words or acronyms that demand two initial capitals. The default entries already there serve as examples.

Figure 9-13. Tweaking Auto-Capitalization

Tweaking Auto-Capitalization

Open Documents Created with Other Programs

Conveniently, Writer has the ability to read or open documents in non-Writer formats. Perhaps most significantly for many people, it can open most documents written in Microsoft Word. A 2003 study conducted by Hal and Christopher Varian at U.C. Berkeley called "MOXIE—Microsoft Office-Linux Interoperability Experiment" indicated that StarOffice 6.0 opened MS Word documents with no noticeable formatting problems 93 percent of the time. That's a pretty good percentage. In fact, because Word users face incompatibilities trying to share files amongst themselves across the different versions of Word, OpenOffice.org is actually more compatible in opening Microsoft Office files than Microsoft Office itself! This is because OpenOffice.org opens all MS Office versions automatically. Meanwhile, users of Word 6.0 (an older version) cannot open or read files in the native MS Word 2000 file format, so it is 100% incompatible with Word 2000.

Calc

Calc is the spreadsheet program in OpenOffice.org. In its basic features and functions, Calc is comparable to Microsoft Excel, so if you're familiar with recent versions of Excel you'll feel quite at home in Calc. However, just as in Writer, you may sometimes have trouble locating a familiar old command in Calc. You may also occasionally have a problem importing an Excel file, although most Excel files should open fine in Calc.

If you are an advanced spreadsheet user, you will be disappointed to learn that Calc cannot run Microsoft Office-originated Visual Basic macros. (There are workarounds, but these are beyond the scope of this book.) More than the other programs in OpenOffice.org, Calc calls for adjustments from Microsoft Office users. However, if you are a basic- or intermediate-level MS Excel user, Calc will probably meet your needs.

To launch Calc, click K Menu→ Use office tools→ Create a spreadsheet. Like Writer, the program may take quite some time to start up.

Open and Save Files

First things first. To open a file in Calc, select File→ Open, choose the desired file in the dialog window, and click the Open button. You can also press the keyboard shortcut Ctrl-O.

To save the currently opened file to its current folder location, simply select File→ Save or use the keyboard shortcut Ctrl-S. If you want to put a file into a new folder (as you need to do when saving a file for the first time), select File→ Save As.... Choose the folder location, enter a filename in the dialog, and press the Save button.

To export your current spreadsheet into PDF format, select File→ Export as PDF.... . Select the target destination folder in the Export dialog, enter or change the filename if you choose, and press the Export button. Alternatively, you can export directly to PDF using the dedicated Export to PDF icon on the toolbar.

Enter Simple Formulas

Just as in Excel, calculations in Calc are performed by entering formulas into the spreadsheet cells. All formulas begin with an equals sign (=). For example, to calculate the result of 1+1, you would type =1+1 and press Enter.

To calculate a result based on other cells, type = in the cell where you want the result to appear, then click on the first cell in the formula. This will highlight the cell in a red outline. Type an operator such as + and click on the second cell, which again will highlight that cell in a red outline. You can enter as many operators followed by cells or other values as you like. Finally, press Enter, and the result will appear in the target cell.

As an example, set the cursor in cell B9 and type =. Next, click on cell B5 and then type -. Click on cell B7 and press the Enter key. The result now appears in cell B9, as shown in Figure 9-14.

Figure 9-14. The formula appears in the Formula Field

The formula appears in the Formula Field

Note that the Formula Field now contains the formula I just described, =B5-B7. As you might have guessed, an alternative way to create the same formula would be to simply type it directly into the Formula Field. First, click once on cell B9; then click once on the empty Formula Bar, type =B5-B7 into it, and press the Enter key. The result is the same.

Sum a Column of Numbers

To quickly sum an existing column of numbers, highlight the target result cell with a single click and then click the sigma icon (it looks like a cross between an S and a Z, and has a tooltip of "Sum") on the Formula Bar. This automatically highlights in blue the most likely nearby column of numbers to be summed (see Figure 9-15).

Figure 9-15. Summing fields A1 through A4

Summing fields A1 through A4

If the highlighted group of numbers is what you want to add up, just press the Enter key and the result will appear in the target cell. If not, grab the small blue square at the bottom right of the highlighted column, adjust the grouping to the precise numbers you wish to sum, and press Enter.

Adjust Column Widths and Heights

To change the width of a column, bring the mouse pointer up into the grid's column headings, which are labeled A, B, C, and so on. The mouse pointer will change to a double horizontal arrow when it rolls over any column divider. When the arrow becomes visible, click your left mouse button and simply move it to the right or left to change the width of the column to the left of the divider. (Use the same procedure to adjust the height of a row, but position the mouse cursor on the top or bottom of a row heading at the left edge of the page.)

To put a column back to its default width, right-click on the column heading to call up the Column Width dialog. Check the empty box labeled "Default value" and click OK. The column will now snap back to its default width (0.89 inches). (To restore a row's default height, use the same technique but apply it at the left edge of the page, on the desired row heading.)

Use Autofill

You can use the Autofill feature to speed up common repetitive tasks. Autofill permits you, in one stroke, to fill in either a column or a row with incrementing numbers. This can be useful when you first create a new table or spreadsheet. In the case of labels, Autofill will simply repeat the label across the cell range you specify.

As an example, enter the numbers 10, 20, and 30 in cells A1, A2, and A3 respectively. Then click and drag your mouse over all three cells to highlight them. You'll see a small black square at the bottom right corner of cell A3, as shown in Figure 9-16. Grab the small square with a left click, and with the left mouse button held down, drag the square down for as many cells as you wish to fill in with numbers. Release the mouse button, and the numbers will fill in consecutively.

I particularly like to use this feature to fill in months. Just type January in a cell, grab the square at the bottom right, and drag down. When you release, all the months will be filled in.

Figure 9-16. Autofill can save time-consuming, repetitive work

Autofill can save time-consuming, repetitive work

Merge Cells

A properly formatted spreadsheet has a lot of text labels to describe the contents. These labels are often long and span across multiple cells. You could enlarge these cells to fit the entire label, but that expands the entire column, which usually looks bad. Instead, it is often better to merge multiple cells together so the label will fit. To do this, first highlight the group of cells you wish to merge and select Format→ Merge Cells→ Define. This will create one single cell that combines the contents of the cells in the range you highlighted.

Calc's recognition of data can be quite sophisticated. For instance, if one column contains Jun and another contains 3, the date 06/03, followed by the current year, appears in the merged cell. However, you'll need to watch out for things like this when you merge cells, as the changes may not always be desirable.

Format Cell Contents

Most spreadsheet users find that a few cell formatting commands carry them through most of their work. The quickest way to format numbers and labels in the cells of a spreadsheet is to use the formatting buttons across the Object Bar shown in Figure 9-17. Calc offers Bold, Italic, and Underline buttons, as well as buttons for justification and simple number formatting.

Figure 9-17. The Object Bar

The Object Bar

If the formatting choices on the Object Bar prove too limiting, you can apply more customized formats by going to Format→ Cells.... This brings up the Format Cells dialog box, which offers a bewildering range of formatting options. I'll discuss just a few of these here.

Underline a cell or cell label

Underlining an entire cell or range of cells is called adding a border. To do this, highlight the range you wish to underline and click on the Borders icon (it looks like a four-paned window) on the Object Bar to open the Borders palette. Click on the underline button in the palette, as illustrated in Figure 9-18.

Figure 9-18. Underlining cells using the Borders palette

Underlining cells using the Borders palette

Note that this is a completely different process from underlining the actual text in a cell. To do this, simply highlight the text you wish the underline and click the Underline icon on the Object Bar (just as with typical word processors).

Change the cell background color

Sometimes you want to dress up a simple table of numbers or make the bottom line stand out by giving the cell backgrounds a little color. You can do this easily in the Format Cells dialog. First, highlight the range of cells you'd like to color. Then select Format→ Cells... and click the Background tab, as shown in Figure 9-19. Choose a color on the color palette with a single click and then click the OK button.

Figure 9-19. Choosing a cell color with the Format Cells dialog

Choosing a cell color with the Format Cells dialog

Format numbers

When you first enter numbers in a cell, they have no formatting. If you'd like to indicate a unit, such as dollars ($12), dollars and cents ($12.43), or a date format, you'll need to apply number formatting. You can also format data with commas to separate thousands.

To format number data, first highlight the desired range to format and then select Format→ Cells.... In the Format Cells dialog, go to the Numbers tab by clicking on it, as shown in Figure 9-20.

Figure 9-20. Formatting numbers with the Format Cells dialog

Formatting numbers with the Format Cells dialog

To format data in thousands, select Number in the Category list at left and choose the desired number format from the Format list in the center. For example, if you want numbers in the thousands to appear with a comma, choose -1,234. Click the OK button, and the numbers in your designated range will appear with the new formatting.

Set the Print Range

When you create a new spreadsheet from scratch, no print range is set. To set a print range for your spreadsheet, turn on Page Break View (View→ Page Break) and highlight the full area you wish to print by clicking on the cell in one corner and dragging the mouse pointer across the entire range. Finally, select Format→ Print Ranges→ Define. Any spreadsheet content that is outside the range you set will not be printed.

If there is a print range already defined and you need to adjust it, simply grab the corner of the blue outline (or just grab a side) with the mouse and stretch it to include all the desired cells of your new print range. To "grab" the blue outline, move the mouse pointer over the outline until you see it turn into a bidirectional arrow. This arrow permits you to drag the outline to a different place simply by clicking and dragging to the desired location.

Use Functions

The functions in Calc, their syntax, and their required formats are well documented in the Help drop-down menu. Select Help→ Contents to open the Help window, and in the Index tab at the "Search term" field, type functions and press the Enter key. Now, you can double-click on the name of a function in the left pane to learn about that function. Figure 9-21 shows the Help information on the financial function PV (present value), which calculates the present value of a stream of regular payments or cash flows and is understandably popular with MBAs and bankers.

Figure 9-21. The Help window for the PV function

The Help window for the PV function

Calc has a full array of function types, including:

  • Financial
  • Database
  • Temporal (Date & Time)
  • Array
  • Statistical
  • Informational
  • Logical
  • Mathematical
  • Textual

When entering a function into a cell, always start your entry with an equals sign (=). Figure 9-22 shows what the PV function formula looks like in the formula field when it's correctly typed into a cell and the necessary information for the function is properly cell-referenced:

=PV(B1;B2;B3)

Figure 9-22. A common mortgage problem, solved with PV

A common mortgage problem, solved with PV

It is also possible to enter numbers as well as cell references into the body of a function. In the formula field, this would look like:

 =PV(.0042;360;-1500)

However, using cell references instead of actual numbers makes it easier to try alternative inputs or generate a sensitivity analysis using a range of choices for one variable.

Create Graphs

In terms of overall quality, Calc's ability to create and render graphs needs improvement, but its functionality is adequate for the simplest types of graphs. In the following example, we'll create a simple bar graph from a table of numbers.

The table we'll be using consists of a column of labels (the different operating systems employed by users of OpenOffice.org) and a column of numbers (the number of responses indicating use of the respective operating system). Since we want to show the relative scale of responses for each category, a bar graph is a good choice. In general, the graph type you select is determined by the type and amount of data you are portraying and by the important points you need to communicate.

The first step is to highlight the range of data to be included in the table, as shown in Figure 9-23. For this particular graph, you want to include the column headings as labels, but exclude the totals row at the bottom because its inclusion isn't necessary for the type of comparison we are making.

Figure 9-23. Highlighting the data to be included in the graph

Highlighting the data to be included in the graph

Next, select Insert→ Chart to open the AutoFormat Chart wizard (see Figure 9-24). Here, you want to check the two checkboxes labeled "First row as label" and "First column as label" to enable the wizard to reference the proper axis labels automatically. Note that your predefined range is already displayed in the Range field, so you don't need to enter or adjust it. Click the Next button.

Figure 9-24. The AutoFormat Chart wizard

The AutoFormat Chart wizard

Let's now adjust a few additional settings to allow the AutoFormat Chart wizard to create an accurate and informative chart. This particular table offers data series in rows (it's a series of one, so don't be confused), so click the radio button for "Data series in: Rows." You should also check the box for "Show text elements in preview." This provides a WYSIWYG (What You See Is What You Get) preview of the bar graph in progress. If the graph or text looks incorrect in the preview, you can click the Back button to adjust your settings or pick a different chart type if necessary. When you've made these changes, click the Next button.

The next dialog allows you to label the main chart title and the axes, and provides a checkbox to include or exclude the legend (see Figure 9-25). Leave the Legend box checked so that you'll know which color bar in the graph represents which OS platform.

Figure 9-25. Entering the chart title and labels

Entering the chart title and labels

Finally, click the Create button, and the graph will appear in the live worksheet (see Figure 9-26). You can now adjust the size or placement of the graph by grabbing the black squares that border the graph.

Figure 9-26. The completed bar graph

The completed bar graph

Sort Data

To sort a list or chart of numerical or textual information, highlight the full range to sort (including the labels, but excluding unwanted data such as totals) and select Data→ Sort. This brings up the Sort dialog box, where you can designate the sorting order, among other parameters (see Figure 9-27).

Figure 9-27. Sorting a simple table

Sorting a simple table

For example, say you want to reorder the data to put the category with the largest number of responses at the top. To do this, you would select to sort by the "Responses per Platform" column and click Descending. Then click the OK button. You'll see how rearranging the order of the source table automatically registers that new order in the bar graph (see Figure 9-28).

Figure 9-28. Table (and graph) successfully sorted

Table (and graph) successfully sorted

The Future of OpenOffice.org

OpenOffice.org 2.0 should become available in the spring of 2005. This version promises decreased load times, overall improved speed, and the addition of a database component similar to Microsoft Access. On top of this, there will be a slew of bug fixes and feature enhancements that will make this already outstanding office suite even better.

Many governments, businesses, and schools are already evaluating the use of OpenOffice.org as a replacement for Microsoft Office. The lack of a license fee and its open document format make it a very attractive program.

Personal tools